[Catalyst] Two problems

Jose Nyimi josenyimi at skynet.be
Wed Mar 30 23:07:12 CEST 2005

> -----Message d'origine-----
> De : catalyst-bounces at lists.rawmode.org [mailto:catalyst-
> bounces at lists.rawmode.org] De la part de Vsevolod (Simon) Ilyushchenko
> Envoyé : mercredi 30 mars 2005 19:00
> À : catalyst at lists.rawmode.org
> Objet : [Catalyst] Two problems
> Hi,
> After trying my Hops example with the newest Catalyst, I get this
> Apache 2 or CGI:
> Can't locate object method "log" via package "Apache::RequestRec" at
> /opt/software/perl/lib/perl5/site_perl/5.8.5/Catalyst/Engine.pm line
> I tried to debug the code under the Perl web server, but it's not
> possible any more - if the code runs under the debugger, each HTTP
> request causes the error below. I tried to look into it, and I think
> happens because Socket.pm tries to read from STDIN, which does not
> right under the debugger. I wish the debugging ability came back.
> Thanks,
> Simon

It seems that Catalyst won't work on Apache2 ...
A similar problem has been reported at this thread

I was expecting Catalyst developers to react on this ...


More information about the Catalyst mailing list