[Catalyst] install Task::Catalyst with ActivePerl

Will Smith willbelair at yahoo.com
Thu Apr 27 22:00:09 CEST 2006

Thank you Stuart,
  It's very kind of you to reply my S.O.S. message. Please send me those files to willbelair at yahoo.com . I will try that. I have tried this command before invoking CPAN:
  and it went through, but the installation got into a loop at Splash , and then went through, with some other errors. I thought I have Cat installed  when seeing the message ...OK..., but it's not. 
  By the way, if you ever moving cat app from SQLite to mySQL, please share you tips on what to do.
  Thanks again,

Stuart McGraw <smcg4191 at frii.com> wrote:
  "Will Smith" wrote:
> Hi,
> I am upgrading my cat app from an old version to the
> latest version from cpan. I'm running cat app on Windows
> 2000. I have the ActivePerl installed. I have
> nmake in the Perl\bin directory. And this is the error
> that I got:
> ---------------------
> CPAN: Storable loaded ok
> Going to read C:\Perl\cpan\Metadata
> [....]
> Undefined subroutine &ActivePerl::Config::find_prog called
> at C:/Perl/site/lib/A
> ctivePerl/Config.pm line 70.
> Compilation failed in require at C:/Perl/lib/ExtUtils/MakeMaker.pm line 7.
> BEGIN failed--compilation aborted at C:/Perl/lib/ExtUtils/MakeMaker.pm line 7.
> [....]
> -----------
> Would someone show me why I get this error. Or if this
> error has been pointed out before, please give the link
> to the thread. Thank you for your help.


That problem can be overcome my making sure you
have Module-Install installed (version 1.61 ppm
from http://theoryx5.uwinnipeg.edu/ppms, not 
version 1.39 from the Activestate repositories).
Then build the Catalyst module manually:
1. delete the Catalyst/inc/ directory.
2. do the "perl makefile.pl / nmake / nmake test...
dance by hand.
If you haven't already installed Catalyst's
prerequisite modules, you will find the same 
problem with some of them.

I was able to install Catlyst-5.66 on Win2K with
AS Perl-5.8.8-817 (with a lot of help from the folks
on this list.)

I wrote a Perl script to repeat the process (which
I tested on a fresh AS Perl install from start to 
finish.) But I haven't tried it with the latest 
Catalyst (am fighting a different fire at the moment, 
hope to get back to the Catalyst stuff soon.) There
are probably dependency changes, and other things
that will require "adjustments" in the script.

If you want it, I'll be happy to send it to you.
(Actually 2 scripts, for Catlyst, and Task-Catalyst)
It uses PPMs (from Active State repo only) to 
get enough stuff so that it can install everything 
else from CPAN. The perl code is really simple
and naive (my Perl knowlage was pretty good back 
in the early Perl 4 days but things have changed 
since then :-) It tries to install all the prerequistites 
modules first, doing the /inc/ fixup where necessary, 
and forcing an install where necessary.

I have MS Visual Studio 6.0 installed on the build
machine, and used that for the pieces that required
compilation. The builtin mingw gcc did not seem to
work for me but I spent 0 time trying to figure
out why. 

Final caveat is that I have not really done anything 
with Catalyst so I do not know if everything was
actually correctly installed. 

Microsoft is to Information Technology, as George Bush 
is to International Affairs. 

Catalyst mailing list
Catalyst at lists.rawmode.org

Blab-away for as little as 1¢/min. Make  PC-to-Phone Calls using Yahoo! Messenger with Voice.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rawmode.org/pipermail/catalyst/attachments/20060427/1c290274/attachment.htm 

More information about the Catalyst mailing list