[Catalyst] Minor Problem With Tutorial

Kevin Monceaux Kevin at RawFedDogs.net
Mon Aug 14 19:45:54 CEST 2006

Fellow Catalyst Enthusiasts,

I'm exploring the wonderful world of Catalyst and trying to work my way
through the tutorial which should be at:


For some reason all that appears to be on that page is an outline of the
tutorial.  The links that should point to the individual sections of the
tutorial don't go anywhere.  But, I found a link at the bottom of the page
where I was able to download the pod files and generate a local copy of the
tutorial on my test box.  

Anyway, I'm at the end of the BasicCRUD section of the tutorial where one
creates the Books::Delete method.  The last line in the method is:


Catalyst appears to be ignoring this statement.  When I tried to delete a
book I got:

Coldn't render template "file error - books/delete.tt2: not found"

So, I tried creating an empty books/delete.tt2 template to see if Catalyst
just wanted to find a template file matching the method it was in before
performing the redirect.  It then displayed the blank page instead of
redirecting to the list method.  I'm sure there is something simple I
overlooked.  Anybody have any suggestions of what I might check?  I'm
running Catalyst 5.7001 on a FreeBSD 6.1 box.

Bruceville, TX

Si hoc legere scis nimium eruditionis habes.

More information about the Catalyst mailing list