[Catalyst] how to get started?

Nate Wiger nwiger at scea.com
Mon Aug 21 18:46:59 CEST 2006

Carl Franks wrote:
> On 21/08/06, burninbruce at yahoo.com <burninbruce at yahoo.com> wrote:
>> I've been trying for days to install Catalyst and haven't gotten
>> far.  I've tried both "perl -MCPAN 'install Task::Catalyst'" and
>> cat-install and they both fail with many errors in various
>> prerequisite modules.  I've tried this on Sun Solaris, NetBSD,
>> and Cygwin, and they fail in similar ways on all three.
> If you post the error messages you get to this list, I'm sure someone
> will be able to help.
> Have you made sure CPAN.pm is configured properly?
> If you get an error with a prereq module, try restarting CPAN and
> installing just that module. Sometimes that works, and if not, at
> least the error messages will be clearer.

A big problem I ran into is that when Module::Build is downloaded via 
CPAN and auto-configured, cc compilation is disabled by default. You get:

     Module::Build is not configured with C_support

So, I had to manually build Module::Build, outside of CPAN, in order to 
get this turned on (it needs a special flag at the command line).

I wish I would've saved all the error output. Several modules were 
missing, throwing fatal errors, and if you manually installed those it 
kinda worked (along with Module::Build reconfig). But not everything was 
properly expressed in Makefile.PL dependencies.

At the end of it, I still wound up with Catalyst 5.6x somehow, which I 
had to reinstall via CPAN again ("install Catalyst::Runtime").


More information about the Catalyst mailing list