[Catalyst] unable to download the catalyst

Matt S Trout dbix-class at trout.me.uk
Mon Sep 18 16:54:29 CEST 2006

John Napiorkowski wrote:
> --- Veerendranadh.Ch at in.standardchartered.com wrote:
>> hi to every one
>> Iam unable to install the
>> catalyst(Catalyst-Runtime-5.7001.tar.gz). while 
>> iam trying to install it is showing this error.
>> ERROR: perl: Version 5.8.0 is installed, but we need
>> version >= 5.008001 
>> at inc/Module/Install/Makefile.pm
>> will i update my version of perl?
>> is there any version of catalyst module which can i
>> run  perl 5.8.0?.
> It's probably more worth the effort to get yourself on
> a newer version of perl.  Catalyst 5.7+ has some great
> features like action chaining as well as more tests
> and improved documentation.  Is there a reason you
> can't upgrade perl?  If you are on a reasonably modern
> linux you could probably do it with a package
> installer such as debian's apt-get.
> I know that's probably not the answer you wanted to
> hear but it's really your best bet to stay modern with
> catalyst.  If you are on an old version of Catalyst
> you are going to have a hard time getting help with
> bugs and other trouble.

And besides, we've needed 5.8.1 since long before 5.50, so it's pretty much 
impossible to get a useful Catalyst without it.

If memory serves 5.8.0 is -theoretically- supported by very early ones but we 
upped the dep to 5.8.1 because stuff like utf8 handling was sufficiently 
fucked 5.8.0 was never really useful for Catalyst use anyway.

      Matt S Trout       Offering custom development, consultancy and support
   Technical Director    contracts for Catalyst, DBIx::Class and BAST. Contact
Shadowcat Systems Ltd.  mst (at) shadowcatsystems.co.uk for more information

+ Help us build a better perl ORM: http://dbix-class.shadowcatsystems.co.uk/ +

More information about the Catalyst mailing list