[Catalyst] MySQL server has gone away

Adeola Awoyemi adeola at digitalcraftsmen.net
Thu Apr 19 14:38:38 GMT 2007

On 19 Apr 2007, at 14:31, Jon wrote:

> On Thu, 2007-04-19 at 13:54 +0100, Adeola Awoyemi wrote:
>> Hi all,
>> I have problem that when I run my app via fastcgi I get an error
>> where one of my models can't connect to the database with the message
>> "MySQL server has gone away". When I start it using 'script/
>> myapp_server.pl' it works fine.
> Would I be correct in guessing that you're using DBI directly, not
> Catalyst::Model::DBI or Catalyst::Model::DBIC::Schema ?


> This problem will occur when a process forks after creating a DBI
> connection, since the connection becomes invalid in the child process.
> See the code in Catalyst::Model::DBI for ways to handle this.

OK. Thanks. I'll have a look and hopefully this will all be fixed.

Its really strange, 'cause it worked for a short while (maybe about  
12 - 24 hours) after deploying it but then it just gave up.

Thanks again Jon and everyone else.

I'll keep you posted.


More information about the Catalyst mailing list