[Catalyst] 2 Catalyst applications on the same server

Octavian Rasnita orasnita at gmail.com
Thu Jun 7 18:46:16 GMT 2007

From: "Matt S Trout" <dbix-class at trout.me.uk>
>> In httpd.conf I have:
>> LoadFile d:/usr/bin/perl58.dll
>> LoadModule perl_module modules/mod_perl.so
>> Include e:/web/MyApp1/include/httpd.txt
>> Include e:/web/MyApp2/include/httpd.txt
> Do you have a NameVirtualHost directive?

Yes I have, and the applications work fine if I run only one of them.


> This is -not- a Catalyst limitation, it's a configuration problem.

I hope. And I hope I will be able to solve it.

> Try starting apache from the command line and see if it errors on start,
> or check the windows system event log.

I have tried starting apache with:
net start apache2.2

But it told that Apache cannot start, and I should use net helpmsg 3547 for 
finding the problem.

That command just shows:

A service-specific error occurred.
Refer to the Help or documentation for that service to determine the 

With other words... no help.

If I try starting apache directly with:

httpd -k start -n apache2.2

...it doesn't display any error message. I see that it doesn't start when I 
try to use this command again and I see that it doesn't complain that a port 
is already used...

No error is printed in Apache's log.
I have also tried to put one of the applications to listen to a different 
port and address, but the server can't start in that case either. It starts 
and works fine if I configure the server to not load one of the 

Both applications load an external perl file using PerlRequire , and those 
files do:

use lib "....";
use MyApp;

and I think that maybe the @INC set by one of the applications or the 
modules it uses, are used somehow in the second application... I don't have 
other idea.



More information about the Catalyst mailing list