[Catalyst] Solved: Catalyst::Plugin::Authentication::Store::LDAP problems

Matija Grabnar matija at serverflow.com
Tue Nov 13 08:32:54 GMT 2007

Peter Karman wrote:
> hm. sounds like you might not have the most current
> Catalyst::Plugin::Authentication module installed. What version are you running?
I can confirm that upgrading Catalyst::Plugin::Authentication to 0.10002 
(the latest version on CPAN at the moment) fixes the problem, and now 
authentication works as per documentation. (I haven't tried fetching 
roles from LDAP yet, that will come later.)

I think it would be useful if you added a version dependency check into 
Catalyst::Plugin::Authentication::Store::LDAP so when the next person 
tries installing it on a slightly older CPAN install they won't run into 
this problem.

Anyway, thank you for this module, it will come in very handy in my 
current project.

Best regards,
                Matija Grabnar

P.S. If you want an example set up for authenticating against Active 
Directory (as opposed to posix LDAP setup, as in your documentation), 
let me know, and I'll send you the relevant config lines.

More information about the Catalyst mailing list