[Catalyst] Cannot preload the app

Octavian Rasnita orasnita at gmail.com
Sun Sep 9 15:34:12 GMT 2007


I've just installed Catalyst on a new computer that runs Windows XP SP2 and 
I cannot preload the application that used to work on the old computer.

If I don't preload it and let the server load it on the first access, it 
works fine, but If I preload it using:

#In httpd.conf:
PerlRequire "e:/web/MyApp/script/preload.pl"

#in preload.pl:
use lib 'e:/web/MyApp/lib';
use MyApp;

then it doesn't work. The web server (Apache 2.2.4) doesn't give any error.

If I comment the line
use MyApp;
then the application works.

I couldn't find anything that could help me. I tried to load it using 
myapp_server.pl but this way also works.
If I run myapp_test.pl then it works but at the end it prints an error:

 (in cleanup) Can't use an undefined value as a HASH reference at 
E:/usr/site/lib/Catalyst/Model/DBI.pm line 104 during global destruction.

First I've installed Apache 2.2.4 for Windows with SSL support, then I 
installed the version without SSL support, but this makes no difference.

Please help!


More information about the Catalyst mailing list