[Catalyst] MojoMojo-0.999005 and mysql

Josef Chladek josef.chladek at gmail.com
Mon Sep 24 06:58:35 GMT 2007

Am 24.09.2007 um 01:37 schrieb Marcus Ramberg:

> On 9/23/07, Josef Chladek <josef.chladek at gmail.com> wrote:
>> Am 23.09.2007 um 13:17 schrieb Marcus Ramberg:
>>> Applied a fix for mysql now, and released  MojoMojo-0.999006.tar.gz
>>> to CPAN. Please test it and give me feedback. (Note,still dont  
>>> have a
>>> working solution for Pg)
>> sorry, but does not work on this end...
> It worked on my end :( Anyways, I have now found a proper fix, which
> does not depend on any deferring of reference checks, and works on
> both mysql and Pg.  MojoMojo-0.999007.tar.gz  is now on it's way to
> CPAN. Please test it and tell me everything is ok ;-)

yup, works now!

fyi, make test fails (not only in the newest version), any hints on  

t/c/page....................NOK 16#   Failed test 'Can show search page'
#   at t/c/page.t line 19.
     mojomojo.conf is the main configuration file and is in  
[error] Caught exception in MojoMojo::Controller::Page->search "Can't  
use an undefined value as an ARRAY reference at /Library/Perl/5.8.6/ 
Plucene/Search/BooleanQuery.pm line 122."

#   Failed test 'can show inline search'
#   at t/c/page.t line 20.
# Looks like you failed 2 tests of 17.
         Test returned status 2 (wstat 512, 0x200)
DIED. FAILED tests 16-17
     mojomojo.conf is the main configuration file and is in  
         Failed 2/17 tests, 88.24% okay

t/schema_DBIC_Attachment....Can't use an undefined value as a symbol  
reference at /Library/Perl/5.8.6/File/MMagic.pm line 576.
# Looks like your test died before it could output anything.
         Test returned status 255 (wstat 65280, 0xff00)
DIED. FAILED tests 1-12
         Failed 12/12 tests, 0.00% okay

More information about the Catalyst mailing list