[Catalyst] Problem installing Catalyst::View::Jemplate

kakimoto at tpg.com.au kakimoto at tpg.com.au
Tue Aug 5 12:11:32 BST 2008

hi all,
 I  had a regression test fail when I tried to install
Did it with the PERL CPAN shell first and got an error. Then, I decided
to go to the directory where Catalyst::View::Jemplate was untarred to
and run make, make install and make test myself.

  Below is the error message. Nevertheless, running "perldoc
Catalyst::View::Jemplate" works but I'm just very curious on why the
test is failing and how to fix it. I tried googling under this keyword,
"Errors installing JEMPLATE  t/01_live.t" and it's not been fruitful.
Please help.

root at nismo:~/codes# cd /root/100/build/Catalyst-View-Jemplate-0.06-loxKog
root at nismo:/root/100/build/Catalyst-View-Jemplate-0.06-loxKog# ls 
blib  Changes  lib  Makefile  Makefile.PL  MANIFEST  META.yml  pm_to_blib  t
root at kagawa:/root/100/build/Catalyst-View-Jemplate-0.06-loxKog# perl
Writing Makefile for Catalyst::View::Jemplate
root at kagawa:/root/100/build/Catalyst-View-Jemplate-0.06-loxKog# make
Manifying blib/man3/Catalyst::Helper::View::Jemplate.3pm
Manifying blib/man3/Catalyst::View::Jemplate.3pm
root at kagawa:/root/100/build/Catalyst-View-Jemplate-0.06-loxKog# make install
Installing /usr/local/share/perl/5.8.8/Catalyst/View/Jemplate.pm
Installing /usr/local/share/perl/5.8.8/Catalyst/Helper/View/Jemplate.pm
Installing /usr/local/man/man3/Catalyst::Helper::View::Jemplate.3pm
Installing /usr/local/man/man3/Catalyst::View::Jemplate.3pm
Writing /usr/local/lib/perl/5.8.8/auto/Catalyst/View/Jemplate/.packlist
Appending installation info to /usr/lib/perl/5.8/perllocal.pod
root at kagawa:/root/100/build/Catalyst-View-Jemplate-0.06-loxKog# make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01_live.........[debug] Creating Jemplate file from
t/01_live.........1/18 [debug] Creating Jemplate file from
[debug] Creating Jemplate file from 

#   Failed test at t/01_live.t line 60.
#     Structures begin differing at:
#          $got->[0] = ''
#     $expected->[0] = 'text/javascript'
# Looks like you failed 1 test of 18.
t/01_live......... Dubious, test returned 1 (wstat 256, 0x100)
 Failed 1/18 subtests 

Test Summary Report
t/01_live.t   (Wstat: 256 Tests: 18 Failed: 1)
  Failed test:  16
  Non-zero exit status: 1
Files=2, Tests=19,  0 wallclock secs ( 0.00 usr  0.01 sys +  0.35 cusr 
0.02 csys =  0.38 CPU)
Result: FAIL
Failed 1/2 test programs. 1/19 subtests failed.
make: *** [test_dynamic] Error 1

thank you,

More information about the Catalyst mailing list