[Catalyst] App testing with Test::WWW::Mechanize::Catalyst

Marius Kjeldahl mariusauto-catalyst at kjeldahl.net
Thu Jul 31 14:23:38 BST 2008

ivorw wrote:
> Have you tried the next step, which is usually
>   $u->get_ok( 'http://localhost/', 'Request should succeed' );


my $APPLOC = 'http://localhost/calapp/no';
$u->get_ok ($APPLOC, 'Application startup');

fails with:

Couldn't instantiate component "CalApp::Model::CalAppDB", "Either 
->config->{connect_info} must be defined for CalApp::Model::CalAppDB or 
CalAppDB must have connect info defined on itHere's what we got:
$VAR1 = bless( {
                  'schema_class' => 'CalAppDB',
                  'connect_info' => undef
                }, 'CalApp::Model::CalAppDB' );
  at /usr/local/share/perl/5.8.8/Catalyst/Test.pm line 90" at 
/usr/local/share/perl/5.8.8/Catalyst/Test.pm line 90

Basically, it's complaining about missing connect_info. When I use 
CalApp "normally" (running script/calapp_server.pl) everything, 
including config with connect_info, is set up like it should.

For some reason, when CalApp is started through the test module the 
CalApp module doesn't seem to initialize correctly.

> Secondly, have you tried running with catalyst debug turned on? You
> might want to run your test with CATALYST_DEBUG=1 in order to see what
> is happening.

It's already running with full debug information. Lots of debug when run 
"normally", nothing when started with the script. Looks like I'm missing 
something vital that will/should kick off the CalApp server "properly", 
but I thought Test::WWW::Mechanize::Catalyst would take care of that 
when I told it to load 'CalApp' in the use statement.


Marius K.

More information about the Catalyst mailing list