[Catalyst] file paths when using catalyst controllers.

Ian Sillitoe ian at sillit.com
Mon Nov 10 19:33:17 GMT 2008

> guys, I updated Catalyst-Plugin-Static-Simple and Catalyst-Plugin-Static
> and tried to run my application again. I am getting this message
> (nothing else has changed).
> " >./server
> Undefined subroutine &Catalyst::Utils::env_value called at
> /usr/local/share/perl/5.8.8/Catalyst/Plugin/ConfigLoader.pm line 173.
> Compilation failed in require at ./server line 56. "

Fairly randomly, I just managed to get the same error.

After reading the comments in Catalyst::Test, I was going to have a look at
Catalyst::Engine::Test. However, it seems this is part of an old Catalyst
distribution so the whole of Catalyst v5.55 ended up getting installed to:


Whereas the up-to-date install is in:


So my solution was to simply delete the old install (then check the
'mbuildpl_arg' and 'makepl_arg' of my local cpan config). You might want to
confirm that you are running a recent version of Catalyst (more specifically
Catalyst::Utils) by something like:

  perl -d -MCatalyst -e ''


  DB<1> M

On a side note - if Catalyst::Engine::Test is deprecated - is it worth
removing/changing the comment on Catalyst::Test? I would offer a patch but I
don't consider myself particularly well qualified.



-- =

Dr Ian Sillitoe
CATH Team -- http://cathdb.info

-- =

Dr Ian Sillitoe
CATH Team -- http://cathdb.info

"Advice is what we ask for when we already know
the answer but wish we didn't" -- Erica Jong
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20081110/55ce1=

More information about the Catalyst mailing list