[Catalyst] Re: make catalyst_par - Error 2

Russ Weight rw8cat at verizon.net
Mon Sep 8 20:21:55 BST 2008


I set this aside for awhile and went with the standard deployment. I
came back to it last week, and my first attempt just worked. However, on
subsequent updates, I get the same error as before.

I have found some emails that imply that if I "clean things up", it will
work. Can anyone provide some clarification? What types of problems lead
to these errors? What should I be looking for?

- Russ

Russ Weight wrote:
> Hi,
> I have been trying to do a PAR deployment, however, when I run "make
> catalyst_par", it appears to run fine for awhile, but ends with:
> Writing PAR "ipw.par"
> make: *** [catalyst_par] Error 2
> After much digging, I found where the error is occurring in the
> _execute method of
> Module::ScanDeps ($VERSION   = '0.84') at the following line:
>    system($perl, (map { "-I$_" } @IncludeLibs), $fname) == 0 or die
> "SYSTEM ERROR in executing $file: $?";
> In this particular case, @IncludeLibs is empty. I'm not sure if that
> is significant...
> $perl and $fname have reasonable values.
> I appreciate any help in understanding this. Is it a bug? Or does it
> indicate that something is missing from my Makefile.PL?
> Is there additional information that I should provide?
> Thanks,
> - Russ

More information about the Catalyst mailing list