[Catalyst] Slow template processing on debian lenny

Terence Monteiro terence at deeproot.co.in
Mon Sep 22 10:53:47 BST 2008

Wade.Stuart at fallon.com wrote:
> Terence Monteiro <terence at deeproot.co.in> wrote on 09/15/2008 10:23:50 AM:
>> Jose Luis Martinez wrote:
>>> Terence Monteiro escribió:
>>>> On my machine, an ubuntu hardy, it works fast - about 2.5 seconds to
>>>> process the template. On a production server using debian lenny, it
>>>> used to
>>>> take around the same amount of time. But recently, I upgraded it to
>>>> libperl
>>>> 5.10 and updated the different Perl modules including Template and
>>>> Catalyst::View::TT. After this upgrade, the same template takes 25
>>>> seconds
>>>> on average to process. The times I am mentioning are the times taken
>>>> on the
>>>> server side, as shown by the Catalyst application debug logs.
>>> Maybe Template Toolkit is packaged without the XS module enabled?
>>> http://search.cpan.org/~abw/Template-Toolkit-2.20
> /lib/Template/Stash/XS.pm
>> When I run
>>   perl -MTemplate::Stash::XS -e 'print "No problem\n"'
>> it tells me that Template::Stash::XS is present.
>> I dumped c.session, c.config and c.stash into a YAML file, read it using
> a
>> script and used the data to process my template. It took just 0.62
> seconds,
>> which is way faster than when C::V::TT processes it. I actually did some
>> tests to verify whether it is a TT problem, but it does not occur when I
>> use the Template module directly. The log information and test results
> seem
>> strange, and I still cannot point my finger on a specific Perl module.
>> Could it be a libperl issue? My libperl5.10 version is 5.10.0-13 from
>> debian lenny.
> try:
> perl -V  I bet you see !5.10.  XS is not binary compatible a lot of the
> time with different perl versions,  it is best to update perl to 5.10 too
> and then reinstall XS modules.
> -Wade

The output when I run perl -V is:

Summary of my perl5 (revision 5 version 10 subversion 0) configuration:
    osname=linux, osvers=, archname=i486-linux-gnu-thread-multi
    uname='linux ninsei #1 smp preempt sun aug 3 22:34:07 pdt 2008
i686 gnulinux '
    config_args='-Dusethreads -Duselargefiles -Dccflags=-DDEBIAN
-Dcccdlflags=-fPIC -Darchname=i486-linux-gnu -Dprefix=/usr
-Dprivlib=/usr/share/perl/5.10 -Darchlib=/usr/lib/perl/5.1
0 -Dvendorprefix=/usr -Dvendorlib=/usr/share/perl5
-Dvendorarch=/usr/lib/perl5 -Dsiteprefix=/usr/local
-Dsitelib=/usr/local/share/perl/5.10.0 -Dsitearch=/usr/local/lib/perl/5.10.0 -D
man1dir=/usr/share/man/man1 -Dman3dir=/usr/share/man/man3
-Dsiteman1dir=/usr/local/man/man1 -Dsiteman3dir=/usr/local/man/man3
-Dman1ext=1 -Dman3ext=3perl -Dpager=/usr/bin/sensible-pa
ger -Uafs -Ud_csh -Ud_ualarm -Uusesfio -Uusenm -DDEBUGGING=-g
-Doptimize=-O2 -Duseshrplib -Dlibperl=libperl.so.5.10.0 -Dd_dosuid -des'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=undef, use64bitall=undef, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -DDEBIAN
-fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE
    optimize='-O2 -g',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fno-strict-aliasing
-pipe -I/usr/local/include'
    ccversion='', gccversion='4.3.1', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t',
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib /usr/lib64
    libs=-lgdbm -lgdbm_compat -ldb -ldl -lm -lpthread -lc -lcrypt
    perllibs=-ldl -lm -lpthread -lc -lcrypt
    libc=/lib/libc-2.7.so, so=so, useshrplib=true, libperl=libperl.so.5.10.0
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -g -L/usr/local/lib'

Characteristics of this binary (from libperl):
  Built under linux
  Compiled at Aug  8 2008 22:12:45

So it seems like perl is at version 5.10

Thanks and Regards,
Terence Monteiro.

DeepRoot Linux,
Ph: +91 (80) 4112 4781 / 85.

More information about the Catalyst mailing list