[Catalyst] size of the uploaded file

Octavian Rasnita orasnita at gmail.com
Sun Jan 4 13:42:09 GMT 2009


I've created a file upload form using C::P::UploadProgress and I am able to
upload small files with it.
I have tried to upload a file that has 696 MB, but only 313 MB of this file
is uploaded in the /tmp directory if I use IE 6 or 108 MB if I use Firefox,
no matter how many times I tried.

Does anyone know if the browsers have some file upload size limits and if
they can be modified?

Under IE, after 313 MB are uploaded, the page finishes "opening..." and it
doesn't print anything although I've used something like:

if ($upload->link_to("/dir/upload/$filename") or
$upload->copy_to("/dir/upload/$filename")) {
$c->stash->{message} = "The file was uploaded successfully.";
else {
$c->stash->{message} = "Error! The file was not uploaded successfully.";

After around 25 minutes, the upload progress shows that the time is
something like 25:45 and the time to go is 42:30 but after a few seconds it
shows that the time to go is 00:00 and after a few other seconds it doesn't
display the upload progress anymore and the page stops loading.

With Firefox, after 108 MB are uploaded, the browser prints an error message
telling that the connection was interrupted, but each time exactly after it
uploads 108 MB.

I have tried to upload the file for more times, and new temporary files were
created, so there is enough free space in the /tmp directory.

I've seen that this limit seems to be no matter if I use a web server on 
another computer or on my local computer.

Thank you for any idea.


More information about the Catalyst mailing list