[Catalyst] Hangs in RenderView in "end"

Gunnar Strand gunnarstrand at yahoo.com
Thu Jul 2 20:33:10 GMT 2009

I found the problem. Turning on debugging for TT (DEBUG => DEBUG_ALL) in TT.pm showed that it hangs on the [% USE CGI %] directive. Apparently

[% USE CGI('-no_debug') %]

is needed. Got it from here:


Seems CGI thinks that it is begin run from command line and prompts for data.


From: Gunnar Strand <gunnarstrand at yahoo.com>
To: The elegant MVC web framework <catalyst at lists.scsys.co.uk>
Sent: Monday, June 29, 2009 6:39:41 AM
Subject: Re: [Catalyst] Hangs in RenderView in "end"

>> Is there any way of running the server in a debugger or to turn tracing on? Can I send a signal to it to get it to >dump a stack trace somehow? Any attempt I've made so far just results in nothing or segmentation faults.
>I don't understand why you're seeing segfaults. What version of Catalyst are you using, what is your perl -V, and do you have the latest version of Variable::Magic installed? Also, if you could attach gdb and get the catalyst process to segfault, then a backtrace from c land could be useful.

The debugger works now(!). I've always had problems with it but hadn't tried it for a while. Maybe a library got updated.

Thanks for the tips!


List: Catalyst at lists.scsys.co.uk
Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
Dev site: http://dev.catalyst.perl.org/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20090702/9ec2a279/attachment.htm

More information about the Catalyst mailing list