[Catalyst] can't seem to install local::lib in dreamhost

Gerda Shank gs364 at cornell.edu
Tue Jun 23 13:36:18 GMT 2009

kakimoto at tpg.com.au wrote:
> hi guys
>  I refered to http://www.catalystframework.org/calendar/2007/8 to
> install local::lib into my dreamhost account.
> I downloaded the tar file for local-lib and extracted it to a place in
> my home dir.
> In changed into the directory that local-lib contents lived in.
> I ran "perl Makefile.PL --bootstrap PREFIX=/home/kakimoto" -- went OK
> I ran "make  test" -- went OK
> I ran "make install" and this is the error I got:
> [apocalypse]$ make install
> mkdir /usr/local/lib/perl: Permission denied at
> /usr/share/perl/5.8/ExtUtils/Install.pm line 112
> make: *** [pure_site_install] Error 13
> [apocalypse]$

I recently installed local::lib on Dreamhost and had a lot of problem, 
many - but not all - of which were caused by the fact that they kept 
killing my CPAN install processes. I saved at least a partial log, and 
this is probably what caused his problem:

[lakers]$ perl Makefile.PL --bootstrap
Attempting to create directory /home/gshank/perl5
Attempting to create file /home/gshank/perl5/.modulebuildrc
ExtUtils::MakeMaker version 6.31 required--this is only version 6.30_01.
BEGIN failed--compilation aborted.
CPAN version 1.8 required--this is only version 1.7602.
BEGIN failed--compilation aborted.
Prototype mismatch: sub ExtUtils::MakeMaker::prompt ($;$) vs none at -e 
line 9.

/home/gshank/.cpan/CPAN/MyConfig.pm initialized.

After which it  tried to use CPAN to install ExtUtils::MakeMaker. Which 
didn't work, of course.

I downloaded and installed it myself by hand in the perl5/lib/perl5 
directory I think. As I recall, I also had to do that with 
Module::Build. Then eventually it got half installed and I and updated 
my .bashrc myself and then...  evenutally I got it all working. I had 
weird problems with CPAN too. I had to end up installing a lot of the 
modules myself.

Gerda Shank

More information about the Catalyst mailing list