[Catalyst] How much RAM do your Catalyst apps use up?

toby.corkindale at strategicdata.com.au toby.corkindale at strategicdata.com.au
Wed Jun 24 09:01:44 GMT 2009

----- kakimoto at tpg.com.au wrote:
> Hi, guys,
>   I have a virtual machine with 256MB of ram. When I run my catalyst
> app
> (ie myapp_server.pl) in the day, it's fine. NEvertheless, when I run
> my
> app from 6pm onwards til midnight, a few clicks on the app to
> retrieve
> some data (the same way I use it in the mornings), and the whole
> machine
> hangs up on me.

I have a few Ubuntu Server virtual machines with 256 MB of ram allocated, which use Postgres 8.3 and Catalyst (under apache w/mod_perl), and they run fine for single-user usage of the application. (They're for testing.. I also have some catalyst+postgres apps running on live sites, but I've never tried those on so little ram!)

I'm surprised the entire machine locks up -- have you tried diagnosing what is going on when that happens?
(eg. checking log files)
Is it defnitely an OOM problem, or something else manifesting?


More information about the Catalyst mailing list