[Catalyst] Bareword "catalyst" not allowed while "strict subs" in use at Makefile.PL line 90.

Octavian Rasnita orasnita at gmail.com
Mon May 3 11:57:10 GMT 2010


I am trying to install a Catalyst-based app under Debian which has Perl 5.1=
0.0 installed.
I've installed the latest versions of CPAN, CPANPLUS, ExtUtils::MakeMaker, =
Module::Install, Module::Build and local::lib using cpan.

Then I tried to run perl Makefile.PL because I was hoping that it will show=
 me the missing Perl modules:

ebroker:/srv/BRK1# perl Makefile.PL =

include /srv/BRK1/inc/Module/Install.pm
Bareword "catalyst" not allowed while "strict subs" in use at Makefile.PL l=
ine 90.
Execution of Makefile.PL aborted due to compilation errors.
ebroker:/srv/BRK1#  =

In the line 90 appears the line:


I have also tried to change it to:


but then it gives the error:

"tests_recursive will not work if tests are already defined at /usr/local/s=
hare/perl/5.10.0/Module/Install/Makefile.pm line 189."

Catalyst::Runtime is not installed because I was hoping that doing `perl Ma=
kefile.PL` would display all the missing modules, including Catalyst::Runti=
me, because it is listed in Makefile.PL. Is there another requirement for u=
sing this command?



__________ Information from ESET NOD32 Antivirus, version of virus signatur=
e database 5081 (20100503) __________

The message was checked by ESET NOD32 Antivirus.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20100503/32319=

More information about the Catalyst mailing list