[Catalyst] building 'local' lib with dependencies for shipping

Octavian Rasnita orasnita at gmail.com
Wed Apr 27 17:09:24 GMT 2011

From: "Fernan Aguero" <fernan.aguero at gmail.com>
On Tue, Apr 26, 2011 at 8:29 PM, Nicholas Wehr
<catalyst at bionikchickens.com> wrote:
> Shipwright is not a silver bullet - it has issues of its own. For catalyst
> projects I created a dependency finder that issues shipwright import
> commands. on top of that, shipwright is not forgiving with regards to build
> errors, for example - a non-uniform Makefile.PL of a CPAN dependency might
> break it... there are ways to tweak a known dependency - but is a pain with
> fully automated build systems.

Thanks again Nick for chiming in.

I edited the Makefile.PL for my app and listed additional dependencies
that I extracted from my app's 'lib' directory.
Now, when I import into the shipyard, it fetches many more
dependencies. However this time, the import fails because of a deep
recursion condition:

Fetching with LWP:
Caught Deep Recursion Condition: /tmp/shipwright_source_dvI8Dl
contains /tmp/shipwright_source_dvI8Dl/cpan-PerlMagick at
/usr/local/share/perl/5.10.1/Shipwright/Source/Compressed.pm line 92
can't dump __require.yml: No such file or directory
cannot remove path when cwd is /tmp/shipwright_source_dvI8Dl for
/tmp/shipwright_source_dvI8Dl:  at /usr/share/perl/5.10/File/Temp.pm
line 902

Tried to google this but found no clue, and almost got no results for
["deep recursion" shipwright] ... any idea if I can manually fix or
work around this?

I haven't found this problem until now, but I have read today about this kind of error and the solution recommended was to reinstall the modules:


and then to try building your packages again.

Note that I haven't even found this problem, so of course that I haven't tried it.



More information about the Catalyst mailing list