[Catalyst] Help Deploying on mod-fcgi Rather than mod_fastcgi

Mark Hughes mhughes at law.du.edu
Sun Feb 13 18:24:41 GMT 2011

I am trying to work through deployng a Catalyst app on an apache2 server 
with mod_fcgi installed.  I don't know what I am doing, and I have spent 
an embarrassingly long time accomplishing nothing.

The app runs okay when I run the standalone myapp_server.pl on the 
server.  Requests from sitename:3000 generate charming debug messages 
and pages appear in the browser -- just as when I run the app locally.

The trouble is that I cannot get myapp_fastcgi.pl to serve pages.  When 
I try to use myapp_fastcgi.pl, the standard debug status messages 
appear, followed by this:

[info] sumo powered by Catalyst 5.80031
FastCGI: manager (pid 14119): initialized
FastCGI: manager (pid 14119): server (pid 14120) started
FastCGI: server (pid 14120): initialized

Seems fine.  But requests result only in 404 errors.

I am stumped and out of things to try.

I have looked at a large number of pages on deploying Catalyst apps, 
including the wiki, advent calendar (several days), 
Catalyst::Engine::FastCGI docs (all three modes), and tried most of 
them.  The only thing I have really discovered is that most of the 
instructions seem to be for mod_fastcgi rather than mod_fcgi.  And most 
of what I have found and tried prevent apache from starting.  (I think 
because mod_fcgi breaks on ExternalServer directives.)

The most promising, because it deals specifically with mod_fcgid, might 
but I don't understand even the basics of how it works.  It doesn't seem 
to tell anything to listen anywhere, and I don't know how to 
successfully start myapp_fastcgi.pl without telling it to listen someplace.

Any suggestions would help.  Thanks.

More information about the Catalyst mailing list