[Catalyst] Inconsistent hierarchy during C3 merge of class

Anne Wainwright anotheranne at fables.co.za
Tue Mar 1 14:42:42 GMT 2011


Was this issue actually resolved, the thread does not indicate so.

I also have had the same problem with the same error messages at the
same place, but one year on from the original post.

I note that the tests and debugging on pp72-73 ran fine (last night,
absolutely), then I ran through the changes on pp74-75 after which then
running the tests all this hassle occurred - tests failing, server will
not start, same error messages as Al Alders at same place.

If there is any definitive reason for this, please tell


On Wed, 24 Feb 2010 17:14:09 -0600
Al Alder <avalder at gmail.com> wrote:

> Using Catalyst 5.80020
> When running CATALYST_DEBUG=0 prove -l t/01app.t
> per 'The Definitive Guide To Catalyst' page 76 I get:
> LolCatalyst-Lite > CATALYST_DEBUG=0 prove -l
> t/01app.t
> t/01app.t ..
> 1/1
> #   Failed test 'use
> Catalyst::Test;'
> #   at t/01app.t line
> 7.
> #     Tried to use
> 'Catalyst::Test'.
> #     Error:  Couldn't load class (LolCatalyst::Lite) because:
> Inconsistent hierarchy during C3 merge of class
> 'Class::MOP::Class::__ANON__::SERIAL::9': merging failed on parent
> 'Catalyst::Plugin::Authentication' at /usr/share/perl/5.10/mro.pm
> line 26. # Compilation failed in require
> at /usr/local/lib/perl/5.10.0/Class/MOP.pm line 101.
> #  at /usr/local/lib/perl/5.10.0/Class/MOP.pm line 105
> Google search turns up the fact that older versions of Catalyst had
> this problem, but this has been fixed in
> the latest versions.  I have checked and all modules versions appear
> to be the latest.
> I think you guys have done an outstanding job with Catalyst and I
> very much want to be able to use it, but
> finding solutions to this has been very frustrating.  Any help that
> you can offer would be greatly appreciated.

More information about the Catalyst mailing list