[Catalyst] (no subject)

Octavian Rasnita orasnita at gmail.com
Thu Aug 30 09:25:12 GMT 2012

From: piet molenaar =

  Subject: [Catalyst] (no subject)


We work with svn were we've committed the schema classes also into the repo=
sitory. =

Using the Catalyst helper script we tried to update the DBIC schema that wa=
s created with =

the Catalyst helper after checkout on another machine and the following err=
or appeared.DBIx::Class::Schema::Loader::make_schema_at(): It is not possib=
le to "downgrade" a schema that was loaded with use_moose =3D> 1 to use_moo=
se =3D> 0, due to differing custom content at /home/danny/perl5/lib/perl5/C=
atalyst/Helper/Model/DBIC/Schema.pm line 635
 I have to mention that we work both on Linux (Ubuntu) and Windows (7) conf=
igurations. The error appeared after building the schema on the Windows mac=
hine; checking it in and subsequently rebuilding (after changes) on Ubuntu.

We also tried to install the latest version of DBIx::Class::Schema::Loader =
and =

the latest Catalyst helper, and then the latest DBIx::Class, and run the =

Catalyst helper to update the schema, but it still gives that error.

What can we do? Where can we specify use_moose =3D> 1 to make it work?

We've looked into documentation but there is no mention about a best practi=
ce of keeping the schema files out of a shared repository. Or am I confused=
I also noted that a similar question was posed on the DBIX mailing list, bu=
t IMHO this list might be more appropriate.

Cheers & thanks in advance,

  Yep, I put that question on DBIC mailing list because actually is about D=
BIC, but got no answer, so if someone on Catalyst mailing list know... plea=
se help.

  I have the same problem. Development on Windows and use in production on =
Ubuntu and then tried to update the DBIC schema on Ubuntu.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20120830/b04c8=

More information about the Catalyst mailing list