[Catalyst] using perldoc on VM

John Deighan john.deighan at gmail.com
Mon Jun 11 20:30:04 GMT 2012

Today I got to Chapter 7 in the Catalyst Tutorial. In there, I found the 

Note: If you are following along in Debian 6 or Ubuntu, you will need to 
install the perl-doc package to use the perldoc command. Use 'sudo 
aptitude install perl-doc' to do that.

Well, though that's late in the tutorial to point that out, it would be 
great if it worked. But it did not:

catalyst at catalyst:~/MyApp$ sudo aptitude install perl-doc
No candidate version found for perl-doc
No candidate version found for perl-doc
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

Also, since there is a suggestion below for "checking my configured 
sources", here is the output from the suggested grep command:

root at catalyst:/home/catalyst/MyApp# grep -Ev '^(#| )' /etc/apt/sources.list

deb http://ftp.us.debian.org/debian/ squeeze main
deb-src http://ftp.us.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

deb http://ftp.us.debian.org/debian/ squeeze-updates main
deb-src http://ftp.us.debian.org/debian/ squeeze-updates main

The blank lines are part of the grep output. Can anyone point me to what 
I have to change to get perldoc working?

On 6/11/2012 2:19 PM, Kamen Naydenov wrote:
> Hi John
> On Mon, Jun 11, 2012 at 7:08 PM, John Deighan<john.deighan at gmail.com>  wrote:
>> It is, in fact, a Debian linux system. That's not a specific system I'm
>> familiar with. And I did try following the instructions. It said that I
>> needed to install perl-doc, so I tried the obvious:
>>         install perl-doc
>> which, of course, did not work. I knew nothing about apt-get and shouldn't
>> be expected to. Now, here's more bad news. I tried using apt-get and here's
>> what I got back:
>> root at catalyst:/home/catalyst/MyApp# apt-get install perl-doc
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> Package perl-doc is not available, but is referred to by another package.
>> This may mean that the package is missing, has been obsoleted, or
>> is only available from another source
>> However the following packages replace it:
>>   perl
>> E: Package 'perl-doc' has no installation candidate
> You need to have properly configured sources.
> To check your sources run this command:
> grep -Ev '^(#| )' /etc/apt/sources.list
> On my stable Debian server output is:
> deb http://ftp.debian.org/debian/ squeeze main
> deb http://security.debian.org/ stable/updates main
> If you don't hvae similar output you will need to edit /etc/apt/sources.list
> May be with command:
> sudo gedit /etc/apt/sources.list
> You can copy and paste lines from output shown above at the bottom of
> file, than save and exit gedit;
> After this run following commands:
> sud
> _______________________________________________
> List: Catalyst at lists.scsys.co.uk
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
> Dev site: http://dev.catalyst.perl.org/

More information about the Catalyst mailing list