[Catalyst] Catalyst - Creating DB dump - Getting “No tables found, did you forget to specify db_schema?” on MS SQL Server connection

Derek W derekwrobel at gmail.com
Tue Sep 11 17:56:24 GMT 2012

I'm trying to create a Catalyst project connecting to an existing MS
SQL Server database. I got the correct connection string and it's
authenticating, but it's not finding any tables. Anyone have an idea
of what I might be missing?

I substituted the real ip address, database name, username, and
password but you get the idea.

This is the command I run:

script\qa_utility_create.pl model DB DBIC::Schema QA_Utility::Schema
create=static "db_schema=DatabaseName" "dbi:ODBC:Driver={sql
server};Server=,1433;Database=DatabaseName" username password

When I run this, I get the below error:

exists "C:\strawberry\perl\site\bin\QA_Utility\lib\QA_Utility\Model"
exists "C:\strawberry\perl\site\bin\QA_Utility\t"
Dumping manual schema for QA_Utility::Schema to directory
C:\strawberry\perl\site\bin\QA_Utility\lib ...
Schema dump completed.
WARNING: No tables found, did you forget to specify db_schema?
exists "C:\strawberry\perl\site\bin\QA_Utility\lib\QA_Utility\Model\DB.pm"

I wanted to quickly get a simple CRUD web app for our existing
database using perl but I'm starting to think this is not going to
happen with SQL server?

Derek Wrobel

More information about the Catalyst mailing list