[Catalyst] Securing a connection

Jesse Sheidlower jester at panix.com
Wed May 22 15:12:51 GMT 2013

On Tue, May 14, 2013 at 01:37:04PM -0400, Jesse Sheidlower wrote:
> I've recently upgraded my Cat to 5.9, and in the process decided to
> switch from the deprecated Catalyst::Plugin::RequireSSL to
> C::ActionRole::RequireSSL. Somewhere along the line, something stopped
> working in my secure-connection activity, and no one found an answer in
> some IRC chat so I thought I'd try here, with an additional question or
> two.

Following up to myself: The ultimate cause was that I had a mistake in
my nginx configuration. Under 5.8 things worked, because 5.8 used its
own heuristics to determine whether a connection was secure, but under
5.9 Cat picks this info up from PSGI, which relies on nginx reporting
things correctly, which it did not because of my mistake. Fixing the
config solved the problem.

rafl++ for helping me figure this out. In passing noted a few areas
where doc upgrades or feature fixes are possible; will be working on

Jesse Sheidlower

More information about the Catalyst mailing list