<div>$ uname -a<br>Linux gonzo 2.6.32.12 #1 SMP Wed Apr 28 19:25:11 UTC 2010 i686 GNU/Linux<br>$ cat /etc/debian_version <br>5.0.8<br></div>
<div>We wound up using cpanm to manually install/upgrade Moose, MooseX::Role::WithOverloading, DBIx::Class, Catalyst::Plugin::ConfigLoader, Catalyst.</div>
<div> </div>
<div>$ perl -MCatalyst -e &#39;print $Catalyst::VERSION,&quot;\n&quot;&#39;<br>5.80030</div>
<div> </div>
<div> </div>
<div class="gmail_quote">On Mon, Jan 31, 2011 at 1:37 PM, Peter Edwards <span dir="ltr">&lt;<a href="mailto:peter@dragonstaff.co.uk">peter@dragonstaff.co.uk</a>&gt;</span> wrote:<br>
<blockquote style="BORDER-LEFT: #ccc 1px solid; MARGIN: 0px 0px 0px 0.8ex; PADDING-LEFT: 1ex" class="gmail_quote">
<div class="gmail_quote">
<div class="im">On 31 January 2011 13:22, will trillich <span dir="ltr">&lt;<a href="mailto:will.trillich@serensoft.com" target="_blank">will.trillich@serensoft.com</a>&gt;</span> wrote:<br>
<blockquote style="BORDER-LEFT: #ccc 1px solid; MARGIN: 0px 0px 0px 0.8ex; PADDING-LEFT: 1ex" class="gmail_quote">Don&#39;t know about this specific problem, but we just ran into something similar -- no upgrades, no changes, but Catalyst suddenly stopped loading (DBIx::Class::Schema::connection(): No arguments to load_classes). Wound up having to cpanm a bunch of upgrades by hand before it started working again. 
<div><br></div>
<div>So apparently our system either is configured for occasional cron-based upgrades and we managed to wind up in an unstable state as a result (still looking into this)... or black hats were involved.</div>
<div><br></div></blockquote>
<div><br></div></div>
<div>Which operating system and version are you running?</div>
<div><br></div>
<div>Regards, Peter</div></div></blockquote></div><br clear="all"><br>-- <br>The first step towards getting somewhere is to decide that you are not going to stay where you are.  -- J.P.Morgan<br>