[Dbix-class] Re: SELECT .. FOR ... (and other db-specific clauses).

Daisuke Maki daisuke at endeworks.jp
Sat Jul 7 17:51:50 GMT 2007

> Looks fairly reasonable. Why are you calling it 'locking' instead of 'for' ?

Absolutely no reason, I just used the naming used in the original post 
that I based my initial changes on.

I suppose

      { ... },
         for => 'update'

Is fair, but within DBIC::SQL::Abstract, it would still be called 
'locking' or 'for_locking' or something like that, otherwise it wouldn't 
make sense.

But that seems like a style matter, and in this particular context I 
don't have a strong preference either way.


More information about the Dbix-class mailing list