[Dbix-class] unable to install via cpan

Christian Walde walde.christian at gmail.com
Thu Jan 5 16:20:51 GMT 2017

On Thu, 05 Jan 2017 08:55:52 +0100, Luca Ferrari <fluca1978 at infinito.it>  

> On Wed, Jan 4, 2017 at 5:26 PM, Christian Walde  
> <walde.christian at gmail.com> wrote:
>> This looks super strange, did you edit that?
> No, but I'm using perlbrew on that machine, if that matters.

No idea, if it always adds those tilde lines, then that would explain the  

>> Did you cut out lines here? If so, please attach the entire log as a  
>> file.
> Uhm..I launched it right now in order to recapture the output and this
> time it worked fine:
> Appending installation info to
> /usr/local/lib/x86_64-linux-gnu/perl/5.22.2/perllocal.pod
>   RIBASUSHI/DBIx-Class-0.082840.tar.gz
>   /usr/bin/make install  -- OK
> Myabe I was in the middle of some system update and libraries were not  
> working?

Tests often depend on various things in your system, also beyond  
libraries, and without seeing which tests actually failed (the parts you  
snipped) it's impossible to tell why it worked now and not before.

Please try and keep all of the output the next time something fails. :)

With regards,
Christian Walde

More information about the DBIx-Class mailing list