[Catalyst] CRUD example templates need Template::Plugin::Class

Gary Ashton-Jones gary_ashton-jones at rta.nsw.gov.au
Fri Apr 8 01:46:25 CEST 2005

This is just a note for any newbies like me who like trying out examples 
in docos (but often don't understand the code they are using).

I tried out the Catalyst::Model::CDBI::CRUD example and templates 
included with the tarball on my Linux box and it worked (eventually 
after I finally tracked down my typing errors). I then installed the 
demo on my iBook and it failed with the following error:

[Thu Apr  7 23:52:12 2005] [catalyst] [debug] Rendering template "list"
[Thu Apr  7 23:52:12 2005] [catalyst] [error] Couldn't render template "plugin error - Class: plugin not found"
[Thu Apr  7 23:52:12 2005] [catalyst] [info] Processing "MyApp::V::TT->process" took 0.250551s

Many hours later I eventually traced the code and found out the error 
meant Template was missing a plugin called 'Class' (yes, that's what the 
error message says but I didn't understand it. (Every module in Catalyst 
starts with 'Class', how does a newbie know which one it meant?).)

I don't know why/how Template::Plugin::Class was installed on my Linux 
box but not on my iBook. I used Bundle::Cat and Bundle::Everything on 
both. Anyway, I installed T:P:C and the demo worked.

IMPORTANT NOTICE: This e-mail and any attachment to it are intended only to be read or used by the named addressee. It is confidential and may contain legally privileged information. No confidentiality or privilege is waived or lost by any mistaken transmission to you. The RTA is not responsible for any unauthorised alterations to this e-mail or attachment to it. Views expressed in this message are those of the individual sender, and are not necessarily the views of the RTA. If you receive this e-mail in error, please immediately delete it from your system and notify the sender. You must not disclose, copy or use any part of this e-mail if you are not the intended recipient.

More information about the Catalyst mailing list