[Catalyst] CRUD example templates need Template::Plugin::Class

Sebastian Riedel sri at oook.de
Fri Apr 8 01:57:33 CEST 2005

Am 08.04.2005 um 01:46 schrieb Gary Ashton-Jones:

> This is just a note for any newbies like me who like trying out 
> examples in docos (but often don't understand the code they are 
> using).
> I tried out the Catalyst::Model::CDBI::CRUD example and templates 
> included with the tarball on my Linux box and it worked (eventually 
> after I finally tracked down my typing errors). I then installed the 
> demo on my iBook and it failed with the following error:
> [Thu Apr  7 23:52:12 2005] [catalyst] [debug] Rendering template "list"
> [Thu Apr  7 23:52:12 2005] [catalyst] [error] Couldn't render template 
> "plugin error - Class: plugin not found"
> [Thu Apr  7 23:52:12 2005] [catalyst] [info] Processing 
> "MyApp::V::TT->process" took 0.250551s
> Many hours later I eventually traced the code and found out the error 
> meant Template was missing a plugin called 'Class' (yes, that's what 
> the error message says but I didn't understand it. (Every module in 
> Catalyst starts with 'Class', how does a newbie know which one it 
> meant?).)
> I don't know why/how Template::Plugin::Class was installed on my Linux 
> box but not on my iBook. I used Bundle::Cat and Bundle::Everything on 
> both. Anyway, I installed T:P:C and the demo worked.

Thanks, fixed it in trunk, also prereq's Catalyst::View::TT now.


More information about the Catalyst mailing list