[Catalyst] how to get started?

Jonathan Rockway jon at jrock.us
Mon Aug 21 22:44:00 CEST 2006

Strangely, I've never had any trouble installing Catalyst.  I usually do
"cpanp install Catalyst::Runtime Catalyst::Devel
Module::Install::Catalyst", and I'm set.  Alternatively, I could just
run Makefile.PL for one of my Cat apps, and that works as well.  (But
for various reasons, I don't keep inc/ in revision control, so I have to
have Module::Install installed on the target machine.  So I have to
install Module::Install::Catalyst first.)

This, BTW, works equally well with plain-old-cpan, but I prefer CPANPLUS.

I did have some problems installing the prerequisites for Angerwhale on
my Cygwin setup, but I submitted patches to the relevant projects, so
that shouldn't be a problem for anyone else.  I encourage others to do
the same.  No bug reports, no fixes.  Maintainers aren't psychic.

> I've been trying for days to install Catalyst and haven't gotten
> far.  I've tried both "perl -MCPAN 'install Task::Catalyst'" and
> cat-install and they both fail with many errors in various
> prerequisite modules.  I've tried this on Sun Solaris, NetBSD,
> and Cygwin, and they fail in similar ways on all three

Include error reports, otherwise we have no idea what's wrong.  Plenty
of other people are using Catalyst on Solaris, NetBSD, and Cygwin, so
it's not a "known issue" that you're reporting.

Finally, as a response to others in the thread, try CPANPLUS::Dist::Deb
if you want to install CPAN modules as packages.  It works great, but
you have to start from scratch from a clean install.  I tried it for a
while; it wasn't worth the effort.  Muck up your CPAN dependencies, and
your security updates won't work (without uninstalling the CPAN modules,
of course).

 However, if you like to be able to uninstall things, that works great.

Jonathan Rockway

More information about the Catalyst mailing list