[Catalyst] IE Cookie problems

Mojo Nichols mnichols at mojosoft.org
Wed Dec 20 01:53:30 GMT 2006

The fix required for me was to set the time on the server.   
Apparently, firefox bases the expiration time on the server time...  
or some other forgiving way and IE bases it on it's system clock.    
Well hopefully this will help someone else.  Thanks to jayk on irc  
for pointing this out.


On Dec 19, 2006, at 12:12 PM, Hermida, Leandro wrote:

> On May 29, 2006, at 11:49 AM, Matt S Trout wrote:
>> Shawn Ferris wrote:
>>> Thanks for the tips -- but nothing is helping unfortunately.. I've
>>> used both the IP address and the hostname, which only contains
>>> alpha chars and still no go. Within fiddler I see that the
>>> Response header has a Set-Cookie record but it doesn't seem to be
>>> doing anything with it.
>>> The authentication seems to be pretty simple in my case.. I have a
>>> login method within my Controller.. This has the form which is
>>> posting the un/pw back to itself.. then upon successful
>>> authentication, I see the session being created in the logs and
>>> then it's redirecting to the "main" page. It's almost taken 100%
>>> from the Cookbook. (There are errors in the code in the Cookbook
>>> that I've had to fix) -- and again, it's working from Firefox. I
>>> think I have everything correct, IE just doesn't take it.
>>> I've also installed Maxthon and used the tools there to clear all
>>> history, cookies, caches, etc.. to no avail. Any other suggestions
>>> out there?
>> IE being retarded, have you tried running the test server with
>> either -k
>> (keepalive) or -f (fork)? I've seen inexplicable problems  
>> magically go
>> away by doing that before (and never show up if you've got an HTTP
>> proxy
>> in front of the test server, or if you're using anything else to  
>> serve
>> the app, or if the phase of the moon is different, and of course if
>> you're using anything except Intarwub Exploder) ...
> Matt is right, the -k switch will fix the problem with IE and cookies.
> When doing the tutorial I used Firefox and didn't notice it but then I
> decided to run it using IE and the login page would show but when  
> trying
> doing the post from the login page it would crap out because it  
> couldn't
> take the cookie.  It was immediately fixed by using myapp_server.pl -k
> Leandro
> _______________________________________________
> List: Catalyst at lists.rawmode.org
> Listinfo: http://lists.rawmode.org/mailman/listinfo/catalyst
> Searchable archive: http://www.mail-archive.com/ 
> catalyst at lists.rawmode.org/
> Dev site: http://dev.catalyst.perl.org/

More information about the Catalyst mailing list