[Catalyst] Missing weak references in my version of Perl

Sebastian Riedel sri at oook.de
Mon Jan 23 17:35:31 CET 2006

23.01.2006 14:49 Karl.Moens at marsh.com:
> Yesterday I tried to update Catalyst to its latest version. CPAN  
> however
> lists lots of errors, mainly of the "Your Perl does not support weak
> references"-form. I am using Activestate Perl 5.8.7 build 813 on  
> Windows
> XP.
> Thinking my Scalar::List::Utils module was in need of an update  
> (which is
> the source of the weak-references) I installed the latest version 1.18
> through ppm, but to no avail. I must have broken something when  
> doing one
> or other upgrade but I cannot trace what.
> Now I remember that some time ago there was a discussion on this list
> regarding a similar problem. Does anyone remember when this was or  
> could
> anyone point me to the right thread, so I can look it up in the
> list-archives?

Do not update!
I had many problems with all versions above 1.14.


More information about the Catalyst mailing list