[Catalyst] Authentication::Store::DBIC works under myapp_server.pl but not Apache/mod_perl

Kevin Old kevinold at gmail.com
Wed Jul 26 18:46:17 CEST 2006

On 7/26/06, Rodney Broom <rbroom+catalyst at rbroom.com> wrote:
> [ Version: Catalyst 5.64]
> I've got a user login that's equivalent to the tutorial. In config, 'user_class' is 'Main::User'. Under myapp_server.pl, all works, but under Apache/mod_perl I get:
>   Caught exception in MyApp::Controller::User->login \
>   "Can't locate object method "search" via package "Main::User" \
>   (perhaps you forgot to load "Main::User"?) at \
>   /usr/lib/perl5/site_perl/5.8.7/Catalyst/Plugin/Authentication/Store/DBIC/User.pm line 19.
> The debug output from each appears to be the same except for this message. I'm befuddled.
> btw, I've also tried setting 'user_class' to MyApp::Model::Main::User, MyApp::Schema::Main::User, and User. Only 'Main::User' works, which makes sense as I read the code.


I've had this same error message several times before.  Usually I need
to upgrade one or all of the modules related to this.

Kevin Old
kevinold at gmail.com

More information about the Catalyst mailing list