[Catalyst] Config problem with C::P::A::S::LDAP under mod_perl

Scott Karns scottkinsf at yahoo.com
Tue Mar 21 22:26:30 CET 2006

--- Scott Karns <scottkinsf at yahoo.com> wrote:

> Hello all.
> I am developing a simple app to allow my users to
> review the status of their pyKota print quota stats.
> I
> am using Catalyst-5.66 and, among other plugins,
> Catalyst::Plugin::Authentication::Store::LDAP-0.03.
> I
> am using C::P::ConfigLoader for configuration from a
> YAML file. When running the built-in server, I have
> no
> problems. Users are correctly authenticated, roles
> are
> handled as intended and my Rose::DB based Models
> function correctly. However, when I run the app in a
> mod_perl2 environment (apache-2.0.55-mpm-prefork and
> mod_perl-2.0.2), I get the following error:
> [error] Can't use an undefined value as a HASH
> reference at
> e/LDAP/Backend.pm line 100, <DATA> line
> 225.\nCompilation failed in require at (eval 6) line
> 3, <DATA> line 225.\n
> This error is reported after the Loaded components,
> Loaded Private actions, Loaded Path actions, and the
> MyApp powered by Catalyst 5.66 reports in the logs.
> I'm still digging, but if anyone else has
> encountered
> this or has an idea as to where to look, I'd be very
> appreciative.
> Cheers,
> Scott

Well, I'm still digging. I tried the app running under
FastCGI on apache2 -- same error.

BTW, there were some typos and apparently some apache1
vs. apache2  issues I encountered in C::M::Tutorial
while trying to get the app running as a FastCGI
script. Most obvious was the spelling of SetHandles
(should be SetHandler.) Apache2 didn't care for the
FastCgiConfig directive either.


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the Catalyst mailing list