[Catalyst] Shared database handles

Eduardo Anuel eanuel at gmail.com
Sun May 7 23:50:28 CEST 2006

I'm pretty sure that's the problem (one connection made that's shared
by all processes) because when I'm running the application there are
several apache processes, but a single connection to the database,
here's an example of the errors I'm getting:

"DBD::Pg::db commit failed: ERROR:  la sentencia preparada <<dbdpg_1>>
ya existe"

It's in spanish but I believe that the translation would be something like :

"the prepared sentence  <<dbdpg_1>> already exists"

And when that kind of error start happening there are Postgres
processes all over the place that say "idle in transaction".

Of course it happens with a lot of other sentences, I tried using
finish after I use a handle but that didn't solve anything, then I
realize that the problem was the connection and tried to bring it down
to force reconnection (just as in the example with Class DBI) but I
haven't been able to do it in the right way.

Think for yourself...Question Authority

More information about the Catalyst mailing list