[Catalyst] Mmap of shared file Operation not permitted

Dennis Daupert ddaupert at sbcglobal.net
Mon Aug 27 15:11:32 GMT 2007

>> Mmap of shared file /tmp/catapult/session_data failed: 
>> Operation not permitted at /usr/lib/perl5/Cache/FastMmap.pm line 496.

Yousef Alhashemi:
> Did you switch between the development server and some other 
> server, like apache/fastcgi? If so, you can either chown 
> /tmp/catapult (and all of its contents) to the appropriate 
> user (e.g. apache or your username), or delete /tmp/catapult 
> and the server you're currently using will just (re)create it
> and be able to read/write to it (but you'll lose your session data).

This may be at OS level; I have a hosted app that suddenly 
stopped working. It's pw protected, alpha, I'm doing local
mods, so didn't spend any time on it. But decided this weekend
to attack it. 

I had not changed anything on the hosted site, but noticed the
apache2 error log statement. I upgraded the OS -- debian etch --
upgraded all perl modules, noticed I could not install 
Catalyst-Plugin-Session-Store-FastMmap as root using CPAN.pm. 
I got same error as above:

t/basic............ok 1/20Mmap of shared file /tmp/sessionstoretest/session_data failed: Operation not permitted at /usr/lib/perl5/Cache/FastMmap.pm line 496.

I installed the debian package for c-p-session-store-FastMmap,
but am still getting the error on startup attempt for my app.

Yes, I also chowned /tmp/catapult/session_data file, that did not work.
I tried deleting  the file, deleted the /tmp/catapult directory, on startup the module successfully recreates the dir and file, but then bombs out. 
I've tried running the app by way of apache2, as well as using the catalyst server both as the app user (www-data) as well as root; "Operation not permitted."

I'll switch to another news group if need be, but I wanted to
first check this list. I am not (yet) well-schooled on just
how Cache/FastMmap works, or why he's not allowed to do that 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20070827/a1aeafdd/attachment.htm

More information about the Catalyst mailing list