[Catalyst] 404 Not Found

Michael Reece mreece at vinq.com
Tue Jan 2 18:59:53 GMT 2007

On Jan 2, 2007, at 9:55 AM, Matt S Trout wrote:

> On 2 Jan 2007, at 17:45, Michael Reece wrote:
>> will things break if i delete the Makefile.PL and define a home in  
>> the config?
>> if so, then my problem is solved!
> Nothing should break at all, although if you want to put the home  
> in the config -file- you'll need to make sure ConfigLoader can find  
> it - see the ConfigLoader docs for details of how to do that.

i am not using a config file, but thanks for the pointer.

> I dunno about your problem being -solved- though - I'd argue that  
> so far all we're seeing is symptoms of the underlying problem "I  
> haven't read enough documentation yet" (or possibly "we don't have  
> pointers in the right places in the docs for you to find them", in  
> which case I'd love to see a patch adding links to the places you  
> looked and didn't find this info :)

the places i looked are the pod docs for Catalyst.pm,  
Catalyst::Manual::*, grepping through everything under site_perl/ 
5.8.8/Catalyst/*, and searching http://dev.catalystframework.org/wiki/

i found a mention of Makefile.PL on http://dev.catalystframework.org/ 
wiki/SolvedIssues but its solution is "make sure to put at least an  
empty Makefile.PL or Build.PL in the application top directory" which  
is not quite what i was after.

i still haven't found it in the docs, so i am not sure what such a  
patch would point exactly!

More information about the Catalyst mailing list