[Catalyst] ACL Plugin

Matt Rosin telebody at gmail.com
Sun Nov 18 10:32:47 GMT 2007

Maybe you are still logged in as another user. Clear cookies and
sessions, look at /tmp.
If you have been running both test daemon and apache you could have
bits from both in /tmp.
Also unless I am mistaken, logically it should not work if you use two
deny_unless statements for the same path as they would together deny
all possibilities for that path. If you want two statements for the
same path, you should use allow_access_if instead I would imagine.
Personally I don't see this problem since I assign a different
module/path per role.

If you are still stumped divide it into two statements and try each
one separately with the other commented out making sure you are
definitely not still logged in as the old user role. Print a debug to
the screen so you can tell what user and role you in fact are and
check to make sure those users are assigned those roles correctly. If
it worked last night and not today you might be in an old state, which
would be solved by shutting down the web server, clearing /tmp and

More information about the Catalyst mailing list