[Catalyst] SOLVED: Warnings on application startup

Marius Kjeldahl mariusauto-catalyst at kjeldahl.net
Mon Oct 29 21:17:01 GMT 2007

I managed to get rid of the warnings. I suspected there were differences
in the various ways in which Catalyst modules can be installed.

Initially I tried the "catinstall" script as "advertised" on the
Catalyst website. When starting to work with it, I guess I needed
additional modules which were not installed by that script, so I
reverted back to the normal way which I usually install packages. In the
Gentoo world this means first checking if there is a package file ready
(an ebuild), and if not using CPAN install.

I haven't bothered figuring out exactly why or when things got messed
up, but the way I managed to get rid of the warnings was as follows:

0) Verify that my app starts with the warnings. Check.
1) Move /usr/lib/perl5/site_perl to /usr/lib/perl5/site_perl.org
2) Start my application. Check for possible missing packages.
3) Install missing packages using Gentoo catalyst overlay. Goto 2)
4) Verify that my app starts without the warnings. Check.
5) Move site_perl.org back to site_perl
6) Verify that my app still starts without the warnings. Check.

It may be that 6. really isn't necessary, but I have not details about
which modules is supposed to be in site_perl versus vendor_perl, so I
wanted to check anyway. This is also consistent with the fact that
vendor_perl is in front of site_perl in @INC.

As suggested by Michael Higgins I may look into g-cpan later to see if
that helps out. Depending on whether the Subversion repository or CPAN
is updated more often, a Gentoo overlay or g-cpan may offer the freshest


Marius K.

More information about the Catalyst mailing list