[Catalyst] Catalyst modperl - child process segmentation fault

Terence Monteiro terence at deeproot.co.in
Wed Dec 10 19:20:11 GMT 2008

Toby Corkindale wrote:
> Terence Monteiro wrote:
>> Toby Corkindale wrote:
>>> Terence Monteiro wrote:
>>>> I'm running my Catalyst application on apache2 using modperl with mysql
>>>> database accessed by DBIx::SearchBuilder. I'm getting the message in
>>>> the
>>>> apache2 error logs:
>>>> child pid 1140 exit signal Segmentation fault (11), possible core dump
>>>> in /tmp
> ]snip]
>>> Ugh.. Dumping core? That's rather drastic!
>>> What versions of DBI and DBD::mysql are you running?
>>> And is DBD::mysql linked against the same mysql client libraries as
>>> mod_php?
>> Thanks, Toby
>> DBD::mysql version: 4.008
>> DBI version:        1.607
>> libapache2-mod-php5 version: 5.2.0-8+etch10
>> How can I find out the mysql client libraries DBD::mysql and mod_php are
>> linked with? What you say is possible because I upgraded DBD::mysql from
>> the latest debian sources in unstable, but not (yet) mod_php. But I don't
>> understand why mod_php should matter.
> Could you humour me, and try disabling PHP in Apache, and then seeing if
> that stops the Catalyst app crashing?
> I think you can do it by 'rm /etc/apache/mods-enabled/*php*.load' or
> something very similar?

Disabled mod_php5 and tried again. Still get the segfaults. Has anyone else
faced this problem, with segmentation faults while running their Catalyst
app with mod_perl 2.0.4-4 on apache 2.2.9-10 or 2.2.9-11 on debian?

> ...

Thanks and Regards,
Terence Monteiro.

DeepRoot Linux,
Ph: +91 (80) 4089 0000
Getting GNU/Linux to work for you. Faster. Better. Today. Every way

More information about the Catalyst mailing list