[Catalyst] ModPerl::Registry

Octavian Râşniţă orasnita at gmail.com
Wed Apr 8 18:19:55 GMT 2009


I know that if possible the mod_perl handlers are recommended and not 
ModPerl::PerlRun and neither ModPerl::Registry, but these options could be 
used to run Catalyst applications in less privileged servers because the 
server doesn't need to be restarted in order to start the application.

I read C::Engine::Apache2::MP20's POD documentation saying that:

    While this method is not recommended, you can also run your Catalyst
    application via a ModPerl::Registry script.


        PerlModule ModPerl::Registry
        Alias / /var/www/MyApp/script/myapp_registry.pl/

    <Directory /var/www/MyApp/script>
            Options +ExecCGI

    <Location />
            SetHandler          perl-script
            PerlResponseHandler ModPerl::Registry

    script/myapp_registry.pl (you will need to create this):


    use strict;
        use warnings;
        use MyApp;

    MyApp->handle_request( Apache2::RequestUtil->request );

Does anyone know why this method is not recommended? Shouldn't it work?

I've tried it and the applications run well the main page (the / URI) but if 
I create another controller and try to access it, it gives a 404 Not Found 

I tried with a pre-made app and with a new MyApp.pm with the same results.



More information about the Catalyst mailing list