[Catalyst] Catalyst::Model::DBIC::Schema - Print Debug statement

Blaine Everingham grandmasterblaine at hotmail.com
Wed Dec 1 23:01:57 GMT 2010

I'm trying to see the queries the actual query code that is submitted to th=
e database when I perform a find on a model.

I've tried:

1) Adding $ENV{DBIC_TRACE}++ to the MyApp.pm
2) Setting the Windows7 Environment variable DBIC_TRACE to 1
3) Setting my run configuration in Eclispe with the arguments -d -r AND Env=
ironment  DBIC_TRACE =3D 1

Each time I run the myapp_server.pl -d -r it does not show the query execut=

Ideally Executing :

$c->model("MyDatabase::UserAccount")->find({  realm =3D> $c->user->auth_rea=
lm,   key =3D> $c->user->url }); =

Would show the query below in STDOUT

SELECT * FROM UserAccount where realm =3D '<user realm>' AND key =3D'<user =

I'm running in a windows environment with strawberry perl and using Eclipse.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20101201/8011c=

More information about the Catalyst mailing list