[Catalyst] Inconsistent hierarchy during C3 merge of class

Tomas Doran bobtfish at bobtfish.net
Fri Feb 26 09:47:56 GMT 2010

On 25 Feb 2010, at 17:55, Al Alder wrote:
> Ran Makefile.PL for Catalyst::Runtime no modules are reported as  
> old.  Using the
> o command in cpanplus shows only the following modules not up to date:
> CPAN Terminal> o
>     1     0.24         0.2702   ExtUtils::CBuilder                    
>     2     1.221        1.222    Glib                                  
>     3   Unparsable     0.009    ModPerl::MethodLookup                 
>     4     1.22         1.221    Pango                                 
> CPAN Terminal>
> Which none of the above appear to be related to Catalyst.
> I also installed the Catalyst-Plugin-ConfigLoader- 
> Environment-0.06_01, thinking this might
> help, but I get the same error.

Ok then, the module which is giving you a hard time isn't in the list :(

As I asked before:

> If this still doesn't solve the issue, can you show us your use  
> Catalyst qw// line (the one with all the plugins), and give the  
> version of each plugin you have installed?

Also, can you check that you have 'use Catalyst' once and once only in  
your main application lib/MyApp.pm file (and not anywhere else)?


More information about the Catalyst mailing list