[Catalyst] Enabling debug mode with fastcgi..

Toby Corkindale toby.corkindale at strategicdata.com.au
Tue Jan 19 00:26:22 GMT 2010

On 19/01/10 06:54, Adam Mackler wrote:
> Hi Toby:
> The output might be going to your web server log.  Try starting your
> fastcgi script with a -e option (with CATALYST_DEBUG set as well).

Looking at the previous posts that Wallace directed me to, it sounds 
like the debug options with fastcgi have been a little broken for some 
time now..
As I said, I've tried the -e (same as -keeperr) options in combination 
with the *_DEBUG environment variables.

I have a vague recollection of having this trouble before, and resorting 
to overriding Catalyst::Log to send things to syslog or a standalone log 

(The front-end apache servers aren't logging any catalyst debug output 
anywhere; possibly this is a config error there, or possibly intentional 
on the part of sysadmins - however either way it's not something I'm 
about to change.)

Hmm, thanks for looking guys.

For what it's worth, or anyone reading this in the archives in the 
future - this is still on Catalyst Runtime 5.8.16.
(.17 was busted, .18 doesn't work out of the box in our environment due 
to some of the changes and so isn't considered production ready by us 
just yet.)
So I'm not sure if the new Cat ScriptRunner code will have fixed the 
issue there.


> On Mon, Jan 18, 2010 at 05:03:23PM +1100, Toby Corkindale wrote:
>> Hi guys,
>> If you're running a Catalyst app with the fastcgi script (as found in
>> scripts/myapp_name_fastcgi.pl), then is there a way to enable the debug
>> mode. (eg. like running scripts/myapp_server.pl -d)
>> I've tried setting CATALYST_DEBUG and MYAPP_DEBUG in the shell
>> environment, but that doesn't seem to work. Either that or else fastcgi
>> is discarding the output somewhere in our case. (I've messed with the
>> -keeperr option too)
>> Cheers,
>> Toby

More information about the Catalyst mailing list