[Catalyst] Help Deploying on mod-fcgi Rather than mod_fastcgi

Mark Hughes mhughes at law.du.edu
Mon Feb 14 14:44:27 GMT 2011

On 02/14/2011 06:42 AM, Nigel Metheringham wrote:
> I'd suggest deleting that /tmp/sumo entirely and letting it recreate.
> Its probably not really a good idea to have it in /tmp shareable by
> different uids either, but to try and get stuff running I'd just zilch
> it for now and then work on analysing how it should be done :-)

I deleted sumo/ and sumo/session_file.  And it worked!  I cannot believe 
it.  Well, I can but . . . I can't believe it was such a simple thing. 
(Isn't one's first "bug" often a permission problem?!)

Here are the new permissions when the file was recreated:

-rw-r----- 1 apache apache 5832704 Feb 14 07:30 session_data

Same for /tmp/sumo.

I'm guessing that when I ran the standalone server, which seemed a 
sensible first step in deploying this thing, it created the /tmp/sumo 
directory and session file.  And then, apache couldn't change it.  I 
never thought to look there and never would have if t0m had not 
suggested looking at apache's strace.

BTW, I think the location of the session_file is chosen by the perl 
module, not by me, but point taken.

Thanks everyone!  I feel relieved and like a dope.  And a bit wiser.

More information about the Catalyst mailing list