[Catalyst] Problem in compiling Catalyst::Engine::HTTP::Prefork due to HTTP::HeaderParser::XS

Len Jaffe lenjaffe at jaffesystems.com
Mon Jun 20 15:37:35 GMT 2011

> Reading DynaLoader.pm line 213 it says that very often programs fail sayi=
> that there's an error in there, but it's really the XS initialization code
> for the module which is really failing. Since my XS skills are, well, clo=
> to zero, I can't trace anything there. How can I trace the loading of an =
> module? I have tried even with strace, but I didn't see anything...
I just worked through an XS loader issue last week.  It typically has to do
with unsatisfied dependencies in the web of shared libs that you're trying
to load.

so find the .so in question, and run ldd on it. ldd will list all of that
library's dependencies, and tell you if it can find them or not. If it can't
then you probably need to add a few libs to your LD_LIBRARY_PATH variable.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20110620/076e6=

More information about the Catalyst mailing list