[Catalyst] Problem in compiling Catalyst::Engine::HTTP::Prefork due to HTTP::HeaderParser::XS

Jorge Gonzalez jorge.gonzalez at daikon.es
Mon Jun 20 19:04:27 GMT 2011

Thaks Len.

I already had done that before posting, no success. It looks like all  
LD dependencies are satisfied:

(after 'make test'):
[jorgegv at desarrollo3 HTTP-HeaderParser-XS-0.20-TnpClr]$ find . -name "*.so"
[jorgegv at desarrollo3 HTTP-HeaderParser-XS-0.20-TnpClr]$ ldd  
	linux-gate.so.1 =>  (0x0040c000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00110000)
	libm.so.6 => /lib/libm.so.6 (0x00d5f000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x0061b000)
	libc.so.6 => /lib/libc.so.6 (0x001fb000)
	/lib/ld-linux.so.2 (0x00682000)

Any more ideas?

El 20/06/11, Len Jaffe <lenjaffe at jaffesystems.com> escribió:

>> Reading DynaLoader.pm line 213 it says that very often programs fail saying
>> that there's an error in there, but it's really the XS initialization code
>> for the module which is really failing. Since my XS skills are, well, close
>> to zero, I can't trace anything there. How can I trace the loading of an XS
>> module? I have tried even with strace, but I didn't see anything...
> I just worked through an XS loader issue last week.  It typically has to do
> with unsatisfied dependencies in the web of shared libs that you're trying
> to load.
> so find the .so in question, and run ldd on it. ldd will list all of that
> library's dependencies, and tell you if it can find them or not. If it can't
> then you probably need to add a few libs to your LD_LIBRARY_PATH variable.
> Len.

More information about the Catalyst mailing list